The Chrysler Minivan Fan Club Forums banner

1 - 20 of 50 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,

2013 Town & Country check engine light came on with a code P06DD. Brought it to the dealer and the said the oil pump needs to be replaced. Oil pressure seems fine, running fine so I find this really hard to believe. Only 20,000 miles and I never had an oil pump go bad on any of my other vehicles. I can see maybe a sensor or something. They didn't have the part so didn't repair yet and light has not come back on yet after a long trip. Is this a known problem or you think they are just trying to make some money since it's under warranty? Any recommendations? Appt is Monday to install new oil pump but I'm thinking of canceling and see if the light comes on again.
 

·
Super Moderator
Joined
·
4,832 Posts
Welcome to the site wassct.
I'm with you, I would not my engine cracked open by someone else unless it was 100% necessary. Warranty or not.

While I have not seen this code P06DD mentioned on this site, a quick Google search shows other vehicles that use the same 3.6L engine having this code. Some owners were told it was there non stock filters causing it, others needed to have their oil pumps replaced.

https://www.google.com/search?q=P06DD&rlz=1C1EODB_enUS542US542&oq=P06DD&aqs=chrome..69i57j69i60&sourceid=chrome&es_sm=93&ie=UTF-8
 

·
Registered
Joined
·
1 Posts
Could this error cause the van not to downshift when wanting to accelerate when already in motion?

As I was getting onto a highway yesterday, the engine light came on and didn't notice anything until the next interchange where I tried to get around a tractor trailer that was ahead of me. I stepped on the gas and nothing. I could manually downshift but automatic was not responding. It shifts back to neutral when stopped and into first when I take off from a complete stop. But the P06DD is the only error the system is reading.

Thanks
Tim
 

·
--UNKNOWN MEMBER--
Joined
·
12,436 Posts
Welcome to the forum.

No, I don't think so.

I had my CEL on for many months due to that code, not any other problem, vehicle ran fine. Been using WIX oil filters until a couple of weeks, took my vehicle to the dealer for something else. Dealer service manager told me I was using the wrong filter, they changed oil and filter. CEL remained on but service manager told me it should turn off after some driving. Sure enough, CEL went off for good.

 

·
Registered
Joined
·
1 Posts
So I got the same code, is the oil pump bad? Had oil leak they said caused the computer problems they cleaned up all contacts had it running normal 3 days then went to this problem. Not in limp mode however it won't coast seems to stay in fourth gear?
 

·
--UNKNOWN MEMBER--
Joined
·
12,436 Posts
So I got the same code, is the oil pump bad? Had oil leak they said caused the computer problems they cleaned up all contacts had it running normal 3 days then went to this problem. Not in limp mode however it won't coast seems to stay in fourth gear?
Welcome to the forum.

Check your pressures on both, low and high RPM's, if OK, then, don't worry.

On my case, I was using Wix filters, no problems gor many changes but one day, right after oil and filter change I got that code along With the C.E.L. I ran it like that for many, many miles, until I visited a dealer in Mexico, they told me that I had the wtong brand of filter, replaced it at not charge and few miles later the C.E.L. banished.

Good luck!
 

·
Registered
Joined
·
1,347 Posts
welcome to the forum . I know this may not apply to our vans but it seems like it's worth mentioning , my brotherinlaw has a RAM 1500 with the 3.6L engine and he had problems with his truck like you described , he had it into the dealer and they changed the oil pump along with a few other parts and the problems remained . Then one of the techs at the dealer decided to pull the oil filter off and found that the garage that did the last oil change didn't put the O-RING back on the filter , once they put it back on he had no more problems at all and that was over 100,000 KM ago.
 

·
Registered
Joined
·
1,010 Posts
So I got the same code, is the oil pump bad? Had oil leak they said caused the computer problems they cleaned up all contacts had it running normal 3 days then went to this problem. Not in limp mode however it won't coast seems to stay in fourth gear?
Hi Royce,

Have you had your vehicle back to the dealership for the coast/fourth gear issues?

Kori
Chrysler Social Care Specialist
 

·
Registered
Joined
·
1 Posts
Check Engine Light won't go off P06DD Code

I'm interested to know if wiredcur has had anymore problems. I have had the CEL light on and off for over a year now with P06DD code. I have had the oil pressure sensor replaced twice and an oil pump and the alternator, lots of money. Check Engine Light still on, had to get a waiver for the inspection sticker because I've spent well over $1000 trying to get the CEL light off and it is still on. The dealer has basically washed their hands of me, they said Chrysler said it is an internal mechanical failure! The only problem I experience is the exact one you describe above "I stepped on the gas and nothing. I could manually downshift but automatic was not responding". Entering the thruway nothing happens when I try to accelerate, stays at 40 mph until I downshift and then upshift with the automatic transmission. Very frustrating, dangerous and expensive.
 

·
--UNKNOWN MEMBER--
Joined
·
12,436 Posts



I'm interested to know if wiredcur has had anymore problems. I have had the CEL light on and off for over a year now with P06DD code. I have had the oil pressure sensor replaced twice and an oil pump and the alternator, lots of money. Check Engine Light still on, had to get a waiver for the inspection sticker because I've spent well over $1000 trying to get the CEL light off and it is still on. The dealer has basically washed their hands of me, they said Chrysler said it is an internal mechanical failure! The only problem I experience is the exact one you describe above "I stepped on the gas and nothing. I could manually downshift but automatic was not responding". Entering the thruway nothing happens when I try to accelerate, stays at 40 mph until I downshift and then upshift with the automatic transmission. Very frustrating, dangerous and expensive.
Look at my previous post bellow, I had same code, US dealer could not fix it. It was a Mexican dealer (Chrysler dealer, not a drug dealer) who found the problem, it was a filter problem, dealer changed oil and filter (for free), they told me the light would go away within 200 kilometers, it did. Never had transmission problems, so your transmission problem should be unrelated.

Change the oil and use a OE filter from the dealer and see if that helps.

Welcome to the forum.

No, I don't think so.

I had my CEL on for many months due to that code, not any other problem, vehicle ran fine. Been using WIX oil filters until a couple of weeks, took my vehicle to the dealer for something else. Dealer service manager told me I was using the wrong filter, they changed oil and filter. CEL remained on but service manager told me it should turn off after some driving. Sure enough, CEL went off for good.

 

·
Super Moderator
Joined
·
24,771 Posts
Look at my previous post bellow, I had same code, US dealer could not fix it. It was a Mexican dealer (Chrysler dealer, not a drug dealer) who found the problem, it was a filter problem, dealer changed oil and filter (for free), they told me the light would go away within 200 kilometers, it did. Never had transmission problems, so your transmission problem should be unrelated.

Change the oil and use a OE filter from the dealer and see if that helps.
Don't see how an oil filter would affect oil pressure that much, oil pressure regulating valve is at the pump, I believe, plus oil filters have a bypass valve that comes into play during cold starts. The 3.6L could be different. Interesting. I think he was a drug dealer, but what the heck, it worked. :)

I don't see your Post bellow. All previous Posts are aboove on my screen. Back at ya. :)
 

·
--UNKNOWN MEMBER--
Joined
·
12,436 Posts
Don't see how an oil filter would affect oil pressure that much, oil pressure regulating valve is at the pump, I believe, plus oil filters have a bypass valve that comes into play during cold starts. The 3.6L could be different. Interesting. I think he was a drug dealer, but what the heck, it worked. :)

I don't see your Post bellow. All previous Posts are aboove on my screen. Back at ya. :)
It doesn't affect oil pressure, but it sets a error code that not even dealers (car dealers) are able to interpret.

When I say see my post bellow, I meant the attached post included on that post. But I get it, wanted to get even! :)
 

·
Super Moderator
2009 Dodge Grand Caravan SXT (3.8); 2003 Dodge Grand Caravan eL (3.8)
Joined
·
2,048 Posts
When I say see my post bellow, I meant the attached post included on that post.
Oh, I thought you were referring to the tone of your post:

Definition of bellow

intransitive verb

1: to make the loud deep hollow sound characteristic of a bull

2: to shout in a deep voice
or did you mean below? :)
 

·
5000 Club
Joined
·
5,727 Posts
Hey LEVY - Is that you when oil prices go down or maybe when you run out of tequila?
 

·
Registered
Joined
·
1 Posts
I'm having the same issue that you describe and they are finally replacing the oil pump under warranty after 6 months of taking it back and forth to the dealer. Every 3 weeks it needed a quart of oil and I don't see it leaking on the ground. They tried to tell me I was using the wrong oil filters, type of oil, etc. etc. They kept saying it needed software updates, I told them to do them. We shall see what it does when I get it back. 2013 T&C with 94,000.
 

·
--UNKNOWN MEMBER--
Joined
·
12,436 Posts
Hey LEVY - Is that you when oil prices go down or maybe when you run out of tequila?
Probably when oil prices are going down.

I'm expecting oil price to go up very soon, my yard is already empty, sold all my inventory last week to different customers. Oilfield workers are happy.
 

·
Registered
Joined
·
2 Posts
Same issue with my 2012 GC 3.6 transmission & check engine light, it won't downshift. I pull over, shut it off, restart & it resets the shifting (check engine light stays on). I don't know the code, but the mechanic recommends an oil pump. Chrysler shop could not find even the oil pump recommendation & left without a repair, but this mechanic has his own shop and found others with this issue. Found out that the oil pump has been updated 6 times by Chrysler, mine has the original version. Did this new oil pump work for others, or the OE oil filter ? Wiredcur & DRSheck, lemme know please.
 
1 - 20 of 50 Posts
Top