The Chrysler Minivan Fan Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys.. Thanks in advance for any help... I have an 01 town n country with all the bells n whistles! 3.8.... Climate control..... My heater quit blowing, so I figured out that the resistor was bad... Changed the blower resistor and then the blower was on hi at all settings... Even with the heater switched off it's blowing on hi.... So I went and got a used climate control unit from the bone yard and replaced it... SAME PROBLEM... BLOWER ON HI, EVERY SETTING, EVEN WITH POWER OFF ON HEATER CONTROL...
 

·
3rd gen > all others
Joined
·
3,394 Posts
Which climate control, knob style or digital button style? Each uses a different "resistor" module for fan speed.

Does it do the same thing if you install the old resistor again, with the "new" climate control?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 · (Edited by Moderator)
Which climate control, knob style or digital button style? Each uses a different "resistor" module for fan speed.

Does it do the same thing if you install the old resistor again, with the "new" climate control?
Haven't tried installing old resistor as it tested bad..... I don't see why that would change anything as it's doing same thing with both climate controls.... But i'll try it.... Knob style...
 

·
3rd gen > all others
Joined
·
3,394 Posts
It's to see if the new resistor is defective and shunting full power to the blower full time. Sometimes new parts are bad right out of the box.
 
  • Like
Reactions: LEVY
1 - 4 of 4 Posts
Top